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Error - Duplicate Invoice Numbers(DNP)


Customer reports that they have duplicate invoice numbers in the current file, with the exact same invoice number.


Cause:

This is typically caused by some problem when processing bills.

Solution:

These can not be voided or deleted from within the system.  The must be manually deleted from the database with the following instruction.

Have all users exit Horizon Billing and make a backup copy of the files.  In this case backup FRMAST.DBF, FRJOUR.DBF  & FRTRAN.DBF.  Those files are located in the HORIZON\FRDATA folder.

Select Start,  Run, type in FDW then click OK
This will take you into FoxDot and you should have a 1 prompt

Type the following commands

SET DEFAULT TO F:\HORIZON\FRDATA (substituting your own drive and directory if yours is not F:\HORIZON)   and press enter; you should receive another 1 prompt (no other message)
USE FRMAST SHARED and press enter; you should receive another 1 prompt (no other message)
SET ORDER TO INVNO   and press enter; you should receive another 1 prompt after a message about the master index
SEEK '12345'   and press enter; you should receive another 1 prompt  (no other message)  Replace '12345' with the invoice number that you are looking for
BROW
When the browse list displays, you can use the CNTR F10 keys to make the screen a bit bigger.  You can use TAB to move horizontally to view fields on the right of the screen that did have have room to display.  SHIFT and TAB will move you back toward the left to view the original fields.
You can arrow up and down or page up and down to move through the invoice numbers.   

You should see a list of invoices, in invoice number order.  If you have duplicates, then you will see 2 lines (records) with the same number.
When you have duplicates, always delete the 2nd occurrence of the invoice

To delete:  highlight the one to delete; hold down your CNTR and T key at the same time
A deleted record will show a small black box on the far left side of the screen.  The CNTR T works like a toggle.  If the record is not deleted, then you use that to delete it.  If the record is deleted, then use CNTR T to bring it back; this way you can retrieve a record if you delete it erroneously.

You may arrow up and down or page up and down to find the invoices that you are looking for.  Or you may hit ESC to exit the browse list and go back up to the SEEK command to go directly to your next invoice

Now follow the same procedure for the file FRTRAN.  However, be aware that FRTRAN contains the detail items entered with charges.  You might have more than one legitimate record here for each invoice number, so you will need to take a closer look at the items to determine which are, in fact, duplicates.  
You can use the BROW command, or you might use one displaying only a limited number of fields, for example
BROW FIELDS INVNO, DESC, CODE, CHGS

Now follow the same procedure for the file FRJOUR.  However, be aware that FRJOUR may contain more than one record here for each invoice number.  When deleting duplicate invoices, you will need to delete only those records with a posttype of I (that's the letter I).   If you recently processed these bills but have not posted payment, or made adjustments, then you will probably see only posttype I.

You can use the BROW command, or you might use one displaying only a limited number of fields, for example
BROW FIELDS INVNO, POSTTYPE, POSTDATE, AMOUNT

When finished with FDW, type QUIT and press enter to exit it.



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  1. Bob Hogan

  2. Posted

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